DLGuard
fully integrated with the major payment systems
Paypal
Clickbank
2checkout
Authorize.Net
Click2Sell
1ShoppingCart
LinkPoint
AlertPay
eBay
PayDotCom
Mal's e-commerce
PagSeguro
CCBill
CommerceGate
DigiResults
FastSpring
JVZoo
MultiSafePay
WorldPay
Plimus
WSO Pro
Paypal Digital Goods
RevenueWire
SWReg
     

Aweber subscription not working
Goto page 1, 2  Next
 
Post new topic   Reply to topic    DLGuard Forum Forum Index -> General Discussion
View previous topic :: View next topic  
Author Message
neilalan



Joined: 13 Jan 2010
Posts: 16
Location: Santa Rosa, CA

PostPosted: Sat Jan 16, 2010 5:18 am    Post subject: Aweber subscription not working Reply with quote

Hi,

We have created a membership site in WordPress and really like the way that DLG is protecting the content. We are using the single payment membership model with 1SC.

I have been unsuccessful in getting the integration with Aweber working. I have followed the clear instructions on the DLG Email Parser in Aweber so that is set up for the list I am using

At first I had added the listname@aweber.com address to the edit product page (in the Aweber box) but that didn't work. Searching around the forum, I found a post that indicated that I should enter that email address into the shopping cart setup page (that wasn't as elegant a solution, because I could only use one list, but, well OK).

Unfortunately, in test after test, the whole process goes smoothly but there is no signup at the list in Aweber. And I don't receive a 'confirm your request for info" email either.

I have read dozens of posts about problems in the past, but for what I understand, this feature is now supposed to be working, correct?

Thanks for any and all help!

Regards,
Neil
Back to top
View user's profile Send private message Visit poster's website
Lionel59



Joined: 14 Dec 2009
Posts: 21

PostPosted: Sat Jan 16, 2010 8:44 am    Post subject: Reply with quote

Hi,

I meet a similar issue.

I have a single product with paypal and Aweber.

The email parser is not always working.

For the 8 last purchases, 2 customers didn't get their email confirmation because Aweber did not receive any adress....
The customer is in my database so the process between paypal and dlguard looks ok.

But sometimes nothing is sent to Aweber.

Please help ! It is a really boring issue.

Does anyone know what to do to fix this ?

Thanks a lot,

Lionel

PS : I also have a free single product with aweber and there may also be an issue because in my database there are 84 customers but in aweber there are only 73 leads (confirmed or not). I will check to see if it is the same issue.
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 31 Jul 2005
Posts: 9393
Location: Australia

PostPosted: Sat Jan 16, 2010 9:28 pm    Post subject: Reply with quote

Hi guys,

There are three main reasons why your signups aren't working:

1) The email isn't being sent

2) The email is being parsed by Aweber

3) Your email address has already been added to permanently removed from the Aweber database.


To find out what's going on, here's a simple test:

On your Edit Product page in DLGuard, in your "Aweber Email" box, put your own email address.

Then do a test sale.


You should recieve the email that normally goes to Aweber.

If you don't recieve it, then it sounds like your hosting provider may not be sending emails, OR they're just really delayed. In this case you'll need to ask your host if PHP's mail() feature is working on your server.

If you DO recieve the email, then this leaves two possibilies:

1) Aweber isn't parsing the email correctly

or

2) The sales email address you're using is already in or been blocked from the Aweber system.


Try using a different email address to purchase with.

Make sure you always return to the download page, as well, as this is where the magic happens.

If there is still no signup, ask a friend to test it. If there is still no signup for them either, contact Aweber and tell them DLGuard is sending the email, give them your AWeber email address, and they'll check it out from their end.

Let me know how you go!
Sam
_________________
Sam Stephens
DLGuard: www.dlguard.com
GuardHQ: www.guardhq.com
-------
Keep up to date with DLGuard and other GuardHQ products: www.guardhq.com/newsletter.php
www.twitter.com/DLGuard
Back to top
View user's profile Send private message Send e-mail Visit poster's website
neilalan



Joined: 13 Jan 2010
Posts: 16
Location: Santa Rosa, CA

PostPosted: Sun Jan 17, 2010 6:50 am    Post subject: Aweber Integration Testing - Jan 2010 Reply with quote

Hi Sam,

Thanks for the helpful information!

I was able to determine that the emails were being sent and the fields listed seemed to match the parser.

I have contacted aweber customer support. I will be thrilled if they anywhere near as responsive as you are!

Regards,
Neil
Back to top
View user's profile Send private message Visit poster's website
Lionel59



Joined: 14 Dec 2009
Posts: 21

PostPosted: Sun Jan 17, 2010 9:43 am    Post subject: Reply with quote

Hi Sam,

Thanks for your reply.

12 customers. For 4 of them, there was the same issue.

I found something that may be interesting : for this 4 persons, I do not have the IP address.
It should certainly have a link.

Is this making you think about something special ?

Because in my case, sometimes it works sometimes not.... So the parser is ok, the email are sent and nothing is BL... What else could I check ?

Have a good day,

Lionel
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 31 Jul 2005
Posts: 9393
Location: Australia

PostPosted: Sun Jan 17, 2010 11:16 pm    Post subject: Reply with quote

No worries Neil, let me know what they say!



Lionel, that's strange that the IP address isn't being picked up. I did a search around on Google, and there were a couple of recommendations for this - one was to upgrade the PHP version because of a possible bug in older versions.

Do you know which version of PHP your server is running?

And who is your hosting provider?

If they're a helpful host, let them know you're reading the "remote_addr" server variable in PHP, and sometimes it's coming back blank. There may be some kind of server setting which affects this, and if it's common on their server, they've probably stumbled across it before.

Let me know what they say!

cheers
Sam
_________________
Sam Stephens
DLGuard: www.dlguard.com
GuardHQ: www.guardhq.com
-------
Keep up to date with DLGuard and other GuardHQ products: www.guardhq.com/newsletter.php
www.twitter.com/DLGuard
Back to top
View user's profile Send private message Send e-mail Visit poster's website
admin
Site Admin


Joined: 31 Jul 2005
Posts: 9393
Location: Australia

PostPosted: Sun Jan 17, 2010 11:18 pm    Post subject: Reply with quote

Hi Lionel,

Actually, before you contat them, can I just clarify what you're saying:

Are you saying they don't have an IP address listed in DLGuard?

If so, then it's a different issue - this means that the customer probably didn't return to the download page.

Do they have any download attempts listed?

And which payment processor are you using?

cheers
Sam
_________________
Sam Stephens
DLGuard: www.dlguard.com
GuardHQ: www.guardhq.com
-------
Keep up to date with DLGuard and other GuardHQ products: www.guardhq.com/newsletter.php
www.twitter.com/DLGuard
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Lionel59



Joined: 14 Dec 2009
Posts: 21

PostPosted: Mon Jan 18, 2010 5:58 am    Post subject: Reply with quote

Hi,

Yes, that's it. I have no IP address listed in DlGuard.
(I got a fifth one yesterday and again no address ip.)

My hosting provider is : Hostmonster. (php version = 5.2.11)
My payment processor is Paypal.

The number of download attempts is always 0. For the other customers too : it's a paid membership site. When everything is ok, paypal sends them to a page with their login information and then Aweber confirms this information.

So it seems that in my case, they are sometimes not sent to download page and in this case no email is sent from dlguard to aweber.

Any idea ?

Thanks a lot,

Lionel
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 31 Jul 2005
Posts: 9393
Location: Australia

PostPosted: Tue Jan 19, 2010 2:46 am    Post subject: Reply with quote

Hi Lionel,

It sounds like that's the case.

Have you had any complaints from these members?


Check the email that is being sent out by DLGuard - does it have direct membership site login details?

If so, maybe change it so it points to your download page instead. That way they'll go to the download page to get their login details.

cheers
Sam
_________________
Sam Stephens
DLGuard: www.dlguard.com
GuardHQ: www.guardhq.com
-------
Keep up to date with DLGuard and other GuardHQ products: www.guardhq.com/newsletter.php
www.twitter.com/DLGuard
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Lionel59



Joined: 14 Dec 2009
Posts: 21

PostPosted: Tue Jan 19, 2010 8:27 am    Post subject: Reply with quote

Hi,

I don't send any mail from dlguard. Paypal sends customers to the download page and aweber (through the parser) is doing the email confirmation.

I will change that and send them to the download page as you advice to do.

But from where does this issue come ? I don't understand why dlguard doesn't send email to aweber if there is not the IP address.

Have a good day,

Lionel
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 31 Jul 2005
Posts: 9393
Location: Australia

PostPosted: Wed Jan 20, 2010 3:15 am    Post subject: Reply with quote

Hi Lionel,

DLGuard still sends the email off, but I'm guessing Aweber is rejecting any submissions that don't contain IP addresses.

Having said that, the email isn't sent from DLGuard until the customer reaches the download/thankyou page. Why? Because we need an accurate IP address to be able to pass to Aweber.

cheers
Sam
_________________
Sam Stephens
DLGuard: www.dlguard.com
GuardHQ: www.guardhq.com
-------
Keep up to date with DLGuard and other GuardHQ products: www.guardhq.com/newsletter.php
www.twitter.com/DLGuard
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Lionel59



Joined: 14 Dec 2009
Posts: 21

PostPosted: Wed Jan 20, 2010 5:47 am    Post subject: Reply with quote

Ok Very Happy
Everything sounds clear.

Thanks a lot for your support.

Lionel
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 31 Jul 2005
Posts: 9393
Location: Australia

PostPosted: Thu Jan 21, 2010 12:53 am    Post subject: Reply with quote

Glad I could help, Lionel Smile

cheers
Sam
_________________
Sam Stephens
DLGuard: www.dlguard.com
GuardHQ: www.guardhq.com
-------
Keep up to date with DLGuard and other GuardHQ products: www.guardhq.com/newsletter.php
www.twitter.com/DLGuard
Back to top
View user's profile Send private message Send e-mail Visit poster's website
VideoGuideToProfits



Joined: 08 Dec 2007
Posts: 148

PostPosted: Sun Oct 03, 2010 4:08 pm    Post subject: Reply with quote

Sam

I've ran 4 tests...

First for the first product, and entered listname@aweber.com in the aweber box... no email was sent.

I tried for the upsell, same thing, different listname, but same thing, no one was added.

So I ran a test with my 2nd email (personal one), and I got the email back, did the same for the upsell, and got the email back.

This is the email I got back when I put my personal email address in replace of the aweber one.

Receipt: SHPLB3TE
Name: Loz Upgrade Test2
Email: myaddy@addy.com
IP Address: (my ip address was there)
Product Number: 2
Product Name: THe Product name

And ran a 5th test putting the emails back in the aweber box for the lists we want populated when they login... nada Sad

Nothing works... Get response works like a charm though, but i used my own account, not my biz's one cos he dont use getresponse.

Can you help please?

Also, there seems to be a intermittent bug, it stores two lots of the same entry, not all the time, just some of the time.

Loz
_________________
Daily Trading System - Ultimate Golden Cross
Back to top
View user's profile Send private message Visit poster's website
admin
Site Admin


Joined: 31 Jul 2005
Posts: 9393
Location: Australia

PostPosted: Sun Oct 03, 2010 7:02 pm    Post subject: Reply with quote

Hi Loz,

It sounds like DLGuard is sending out the email fine then, since it's sending to your own email address.

This means it's not being processed by Aweber, for some reason.

Double check your "support email address" as set up on your Config screen is a valid email. Just a straight email address, nothing tricky in there?


Next, double check the Aweber email address you're entering - make sure it's set to the correct email.

Also, double check everything is set up like this page lists:

http://www.aweber.com/faq/questions/550/How+Do+I+Integrate+DLGuard+with+AWeber%3F

If you're still having troubles, email Aweber and tell them what's happening, and that the email is being sent fine, but just not processed.

Maybe they have a log of what emails are sent in, and why they're not being processed.

Let me know what they say!


Regarding the double listings - they're not actually double listsings, it's just a weird bug in the Search feature where if you put something small enough into the search box (such as "a"), then it can sometimes return double listings.

I'll have this fixed for the next version!

cheers
Sam
_________________
Sam Stephens
DLGuard: www.dlguard.com
GuardHQ: www.guardhq.com
-------
Keep up to date with DLGuard and other GuardHQ products: www.guardhq.com/newsletter.php
www.twitter.com/DLGuard
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    DLGuard Forum Forum Index -> General Discussion All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group